How to fix missing workspaces in Codecov for Bitbucket Cloud

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

This knowledge-based article explains how to solve an issue where the third-party application Codecov does not show your desired workspace.

Diagnosis

You've logged in to Codecov using your Bitbucket Cloud account; however, you can't see one of your shared workspaces from the drop-down selection on the left.

Cause

It appears that your Bitbucket Cloud account may have been connected to Codecov before you were granted administrator access to your shared workspace.

As a result, Codecov is unable to locate the workspace.

Solution

To resolve this issue, please ensure that you have been granted proper administrator access and try to do the following from your end:

Updated on March 20, 2025

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