Bitbucket cloud: Removing users from Project or Repository Settings still shows under "Users on Plan"

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

In Bitbucket Cloud, users can be granted permissions either at the workspace, repository, or project level. You might run into a scenario where removing a user from repository permissions and/or project permissions(direct or via group) will not remove the user from the "billable" user list.

Cause

When a user is removed from either the repository or project, the user might remain a part of the workspace(workspace member). You can see the user is still listed under the 'Users on Plan' section, and the user will be billed. This is cause the user might be part of a workspace group that doesn't have access to any projects or repositories.

As per our recent blog post: billing model, any user who is part of the workspace will be counted against the license and will be billed irrespective of their access to private content in the workspace.

If you are on a free plan, the user will still count toward the 5-user quota.

  • Example

    • For instance, Let's consider this scenario where the users Suhas and Suyog have direct permissions to a repository.

      (Auto-migrated image: description temporarily unavailable)

      Admins can also verify a user's access by following these steps:

      • Go to "Workspace Settings."

      • Click on "User Directory" under access management.

      • Select the user for access verification.

      • Click on the three dots (...) for more options.

      • Choose "View Access" to check the user's permissions.

    • User Suhas has been removed from the repository permissions.

      (Auto-migrated image: description temporarily unavailable)
    • Even after removing the user from repository permission, we can still notice the user is still present under the "User's on plan" section.

      (Auto-migrated image: description temporarily unavailable)

Solution

According to the new billing model, users will be billed if they are part of the workspace, regardless of their permissions for private or public repositories/projects. Therefore, users will still be billed or count toward the 5-user quota in case of a free plan.

To address this issue, you'll have to remove the user(if no longer needed) from the workspace completely. To do so, navigate to Workspace Settings > User Directory > from the dropdown select the users on plan >> Select the user and remove the user from the workspace. This action ensures that the user is no longer part of the billing plan.

(Auto-migrated image: description temporarily unavailable)
Updated on April 11, 2025

Still need help?

The Atlassian Community is here for you.