Troubleshoot AWS pipes

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Below is a list of issues or errors that arise, and their potential solutions when using AWS Pipes. We also encourage you to use the Atlassian Community to find answers and ask questions about building your own pipelines. If a feature of Bitbucket is causing problems, contact our Support team.

Atlassian Support can't help with problems with your own scripts and tools.

Diagnosis

Error “… (InvalidClientTokenId) …: The security token included in the request is invalid“

This error occurs when the user failed to pass authentication. Either the appropriate user is not active or user access keys are not valid.

Solution

Resolve authentication issues by following steps:

  • ensure that the AWS keys repository variables used in the repository are valid, accurate, and contain no spaces or typos

  • ensure that the corresponding user is active in the AWS console

In specific situations, someone who also has access to your IAM console could delete a user by mistake. If this is the case, create the user again with the appropriate permissions.

Error “…user is not authorized to access following resources….“:

This error occurs when a user doesn’t have the necessary authentication. This happens when the appropriate permissions are not set or the user doesn’t have all the necessary permissions.

Solution

Resolve this error by following the steps below:

  • make sure the user has the necessary permissions assigned to them. Go to the AWS IAM console and check the set of current permissions (AWS IAM managed, inline, and custom policies that are used to define permissions)

  • make sure you have set up AWS IAM permissions properly, so users have the necessary authorization. Sometimes it can be difficult to figure out within the AWS console what IAM permissions should be added, especially when granular permissions are set up for a user. For that follow Policy conditions for extra security, Troubleshooting AWS Policies, and AWS IAM troubleshooting guides to pass authorization.

Error “…stack in ROLLBACK_IN_COMPLETE (ROLLBACK_IN_PROGRESS, …) state

This error means that something went wrong when executing some actions on your AWS Cloudformation stack. It could also be an authorization error or another error that happened when an action was deployed.

Solution

Resolve this error by following the steps below:

  1. Go to your stack in the Cloudformation console.

  2. Select the Events tab. All the errors that happened while executing actions on the stack should be displayed here.

  3. Resolve all the errors (authorization errors, non-existing issues, etc.).

  4. Repeat your deploy.

If you have more questions that are not listed on this page, use the Atlassian Community to find answers and ask questions about building your own pipelines.


Still having problems?

Contact Atlassian Support. We'll be happy to advise you. Please include as much detail as possible, where applicable:

  • Logs from the affected application (if applicable)
  • Screenshots of the error message (if they're not covered in logs)
  • Information about the steps you've taken previously

Last modified on Dec 2, 2022

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