Remote Triggers using Webhooks stop triggering Bamboo builds consistently

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

On some occasions, Bitbucket Cloud Webhooks might start delaying the triggering Bamboo builds, giving the impression that the triggers are not working.

Environment

Bamboo, connected to Bitbucket cloud using remote triggers to trigger builds.

Diagnosis

You can access the following webpage to check the size of the "Pending events" queue:

  • http://<bamboo URL>/admin/viewBambooInternals.action

This number usually is close to zero, if it's not, make a new commit to the repository and monitor the plan to check if it will be triggered after some time (it might take a few hours). If after a couple of hours the plans didn’t get triggered, you are probably being impacted by a different problem like Atlassian IPs not being properly whitelisted in your proxy. 

Cause

There are many reasons for this to happen but one of the most common ones is that the queue is being filled up by multiple repositories failing to authenticate with the credential provided or the repository is not reachable anymore (e.g. Decommissioning of Bitbucket Server instance after migrating the repositories to Bitbucket Cloud)

Solution

Check the pending event queue items trying to identify from which plans the majority of the events are coming, with that in hand, check if the repositories used by these plans are functional. You can also check the atlassian-bamboo.log files to see if there are errors related to repositories to not being able to connect/authenticate.

If this is not the case, please feel free to reach the Atlassian support team

Updated on March 12, 2025

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