ERR_TOO_MANY_REDIRECTS error seen on the browser while logging into Bamboo

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

While login into Bamboo ERR_TOO_MANY_REDIRECTS error is seen on the browser.

Environment

Issue seen on Bamboo 6.8.3 but might be applicable for any supported version. 

Diagnosis

When opening the Bamboo URL, it will open the allPlans.action page properly and will display the list of project and plans based on the security setting in place.

The issue occurs when we try to login and below error is seen on the browser.

1 2 3 This page isn’t working localhost redirected you too many times. Try clearing your cookies. ERR_TOO_MANY_REDIRECTS

Cause

There are possible two causes for this.

  1. Problem on the client side (browser caches , corrupt cookies , unsupported browsers etc).

  2. Problem with the proxy setting between Bamboo and the proxy server.

Solution

Solution 1 : 

For the problem related to client side, please try to clear the browser cache and cookies and also try to access Bamboo in another supported browser ( Edge, Chrome, Firefox, Safari ). 

Solution 2 : 

If the above step does not solve the problem, then the problem seems to be on Bamboo - proxy server side.

Open server.xml file via <bamboo-install>conf>server.xml and look for configurations related to proxy setting in the Tomcat connector, look for below properties. 

1 2 proxyName="mycompany.com" proxyPort="443"

While writing this page the issue was incorrect proxy details were added to server.xml and by removing that the error was gone. Bamboo needs to be restarted for this change to take effect. 

There are couple of other things to note 

  1. Is the proxyName correct or wrong proxy details are present in server.xml file , if that is the case ERR_TOO_MANY_REDIRECTS error would be seen on the screen. To solve this correct the proxy setting on server.xml file and restart Bamboo. 

  2. If the proxy configurations on the proxy server are not done properly then this error would be seen, there are couple of pages which highlights how to correctly set reverse proxy on bamboo, please refer below for correct configurations. 

Updated on March 20, 2025

Still need help?

The Atlassian Community is here for you.