Can't log in to Bamboo when using Crowd as the User Directory

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When users attempt to log in to Bamboo, the application experiences prolonged loading time preventing access.

Environment

All Bamboo versions using Crowd to manage users' accounts.

Diagnosis

Bamboo tries to authenticate the user from Crowd but the login page keeps loading and doesn't log in.  In the <BAMBOO_HOME>/logs/atlassian-bamboo.logs we can see the following message:

1 2 WARN [scheduler_Worker-7] [CrowdClientControl] Failed to refresh the user and group cache com.atlassian.user.EntityException: com.atlassian.crowd.exception.ApplicationPermissionException: HTTP Status 403 ForbiddenType Status ReportMessage Client with address "<ip address>" is forbidden from making requests to the application, bamboo.Description The server understood the request but refuses to authorize it.

If logged in with a local user, you should be able to see a similar message by going to Bamboo Administration > Overview > Security > User directories, selecting the Crowd User directory, and clicking on the Test Settings button located at the bottom of the page.

Cause

A possible cause is related to an incorrect Bamboo IP address added to the Crowd application.

It's expected that Crowd allows connections from the same IP address configured to every application added and refuses to authorize/authenticate any different addresses. In this case, Bamboo is trying to get authorization from Crowd while users try to log in; however, since the user manager application refuses the IP address reaching out, the users experience the symptom of slowness.

Solution

  1. Access the Crowd instance

  2. Click on Applications > Bamboo application related

  3. Go to Remote addresses

  4. Remove the incorrect IP address by clicking on the Remove option

  5. Add the correct Bamboo IP address

Updated on February 28, 2025

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