Bamboo schedule backup fails with error 'Unable to find Plan'

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

This document addresses a concurrency error in Bamboo during the backup process which results in the backup failure with the error message Unable to find Plan present in the logs.

Environment

Bamboo 7.0 and above.

Diagnosis

The following error can be found in <bamboo-home>/logs/atlassian-bamboo.log file:

1 2 ERROR [scheduler_Worker-10] [XmlMigrator] Problems occurred while exporting com.atlassian.bamboo.migration.stream.MapperExportException: java.lang.IllegalStateException: Unable to find Plan for PROJECT-PLAN-1

Cause

The cause of this failure is that the Expiry process which is running in the background, can be deleting some plans, log files, and artifacts, and it may be running at the same as the backup process. The backup tries to backup these files which in fact may have already been deleted.

Solution

The recommendation is to run the expiry and the export in different timeframes to avoid this kind of concurrency problem. Change the backup schedule to a different time by following this documentation: Specifying a backup schedule.

Updated on March 10, 2025

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