Bamboo remote agent fails to connect with SSLException: Unsupported or unrecognized SSL message

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Bamboo remote agent fails to connect with SSLException: Unsupported or unrecognized SSL message.

Diagnosis

You may see the below error message in the $BAMBOO_AGENT_HOME/atlassian-bamboo-agent.log file

1 2 INFO | jvm 1 | 2023/02/02 13:13:12 | javax.net.ssl.SSLException: Unsupported or unrecognized SSL message INFO | jvm 1 | 2023/02/02 13:13:12 | at sun.security.ssl.SSLSocketInputRecord.handleUnknownRecord(SSLSocketInputRecord.java:457) ~[?:?]

Cause

javax.net.ssl.SSLException: Unsupported or unrecognized SSL message can occur if protocols on the connection address are incorrect.   For example, if you specify a port that is NOT SSL but you choose settings that try to connect via SSL, this can occur.  It is the equivalent of trying to browse HTTPS protocol on a webserver port that is only listening for HTTP protocol.

You can check the configuration on the Bamboo's Base URL and Broker client URL in the Administration → Overview → System, select the General configuration page

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Solution

  1. Verify the configuration of the Bamboo's Base URL and Broker client URL  are with the correct protocol in use. If necessary update the value and restart Bamboo Server.

  2. Please check the Bamboo Base URL or the page  Installing a remote agent and  Running a remote agent section to find the correct URL for remote agent installation. Ensure this address is reachable by the server you're running the remote agent from.

  3. Verify and if necessary update the $BAMBOO_AGENT_HOME/conf/wrapper.conf file and adjust the wrapper.app.parameter.2=<bamboo-server-URL>/agentServer/ with the correct value and protocol. 

  4. Restart the Bamboo Remote Agent

 Please check the articles below for securing the Bamboo server and Bamboo remote agent.

Updated on March 21, 2025

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