Bamboo Manage apps page throws "Page not found Exception"

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

While navigating to "Manage Apps" page via below 2 options, "Page not found" exception is seen.

  1. ⚙️ > Manage apps

  2. Directly via the URL : "https://{bamboo-url}/plugins/servlet/upm"

Environment

Issue seen on Bamboo 8.2.1.

Diagnosis

  • Try to visit the "Manage Apps" page via the options described under the summary section, "Page not found" exception will be seen.

  • Also while navigating to ⚙️ > Overview > Manage Apps section, "Find new apps" and "Manage apps" sections are missing, please refer below.

(Auto-migrated image: description temporarily unavailable)

Cause

  • The first cause is Incompatible Universal Plugin Manager (UPM) Installed on the Bamboo Instance.

  • The second is on the DB side , UPM is in a disabled state.

Solution

Solution 1 for Incompatible versions on the server :

  • By default Bamboo ships a default supported version of UPM which is present in <bamboo-install>/atlassian-bamboo/WEB-INF/atlassian-bundled-plugin as atlassian-universal-plugin-manager-plugin-x.x.x.jar

ℹ️ The version of the jar may vary based on the version of Bamboo, for 8.2.1 supported jar version is atlassian-universal-plugin-manager-plugin-4.3.4.jar

  • The first step is to look for <bamboo-install> and <bamboo-home> folder to find if there are any incompatible Jar's present especially in below folders. If any atlassian-universal-plugin-manager-plugin-x.x.x.jar is found, please take a backup of the jar's and delete the jar's from these folders. Following command can be used to run the search.

1 find . -name "*atlassian-universal-plugin-manager-plugin*"
  1. <bamboo-home>temp

  2. <bamboo-home>caches

  3. <bamboo-home>shared/plugins

  4. <bamboo-install>temp

  • Please restart Bamboo and see if the manage App's page is visible or not.

Solution 2 for Disable plugin state on DB :

  • If the Issue still exists, please run the below query in the Database.

1 select * from bandana where bandana_key like 'bamboo.plugin.state'
  • The below entry should be marked as true from the results above.

1 <string>com.atlassian.upm.atlassian-universal-plugin-manager-plugin</string> <boolean>true</boolean>
  • Please restart Bamboo post doing the changes on the DB side.

  • The Issue should be resolved now.

Updated on April 2, 2025

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