Bamboo fails to start due to "fatal bootstrap Bamboo bootstrap failed: failed to find config at: bamboo.cfg.xml"

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Bamboo may fail to start due to the error fatal bootstrap Bamboo bootstrap failed: failed to find config at: /<bamboo-home>/bamboo.cfg.xml

Environment

9.2.1

Diagnosis

  1. When checking the atlassian-bamboo.log we can find a stack trace which is generated while Bamboo is trying to start:

    1 2 3 4 5 2023-08-21 21:20:56,381 FATAL [main] [BootstrapUpgradeManagerImpl] Task 80008 failed com.atlassian.bamboo.upgrade.exception.ValidationException: Failed to acquire the local home lock. Is another Bamboo instance running on the same local home? at com.atlassian.bamboo.upgrade.tasks.validation.LockLocalHome.doUpgrade(LockLocalHome.java:30) ~[atlassian-bamboo-web-9.2.1.jar:?] ... 2023-08-21 21:20:56,396 FATAL [main] [DefaultBootstrapManager] Validation tests failed: Failed to acquire the local home lock. Is another Bamboo instance running on the same local home?
  2. Ensure the user with which Bamboo is starting has the correct permissions to start Bamboo as mentioned here: Fixing Bamboo files and folder permission for Linux installations

  3. Check if there are multiple Bamboo processes running using ps -ef | grep bamboo command.

Cause

You can see this error due to below reasons:

  • Bamboo user does not have the correct permissions to start Bamboo.

  • There could be multiple Bamboo processes running whilst starting Bamboo.

Solution

Based on the causes identified in the above section:

  • In order to resolve the issue, if it is due to incorrect permissions to the Bamboo user, then make sure to provide the correct permissions as mentioned in Fixing Bamboo files and folder permission for Linux installations.

  • In case the issue is that there are multiple Bamboo processes running, make sure to follow the below steps:

    • Stop the Bamboo process using<bamboo-home>/bin/stop-bamboo.shcommand.

    • Check the Bamboo processes using the ps -ef | grep bamboocommand.

    • Kill all the Bamboo processes using thekill -9 command.

    • Once all the processes are stopped, start Bamboo using the <bamboo-home>/bin/start-bamboo.sh command.

Updated on February 25, 2025

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