Bamboo Data Center fails to install/update app: Error Installing/Upgrading Plugin from Atlassian Marketplace
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When installing or upgrading a plugin from the Atlassian Marketplace, you might encounter the error message 'Error downloading plugin from https://marketplace.atlassian.com/download/apps/<APP_ID>/version/<VERSION_ID>'.
This typically happens when the system cannot connect to the Atlassian servers due to network restrictions like firewalls, proxies, or load balancers blocking the connection.
Environment
The solution has been validated in Bamboo 9.2 but may be applicable to other versions.
Diagnosis
The following error message can be seen in the<bamboo-home>/logs/atlassian-bamboo.log
indicating that Bamboo cannot reach the Atlassian Marketplace.
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INFO [UpmAsynchronousTaskManager:thread-1] [PluginDownloadServiceImpl] Downloading plugin artifact from [https://marketplace.atlassian.com/download/apps/<APP_ID>/version/<VERSION_ID>]...
ERROR [UpmAsynchronousTaskManager:thread-1] [DownloadingInstallTask] Error downloading plugin from https://marketplace.atlassian.com/download/apps/<APP_ID>/version/<VERSION_ID>
Cause
The issue is likely caused by the system's inability to connect to the Atlassian Marketplace due to network restrictions. This is often due to interference from firewalls, proxies, or load balancers that prevent the Universal Plugin Manager (UPM) from reaching the necessary servers to download the plugin.
Solution
To resolve this issue, you need to configure your firewall or load balancer to allow UPM to connect to the necessary Atlassian servers. Specifically, you should:
Check whether a firewall is blocking UPM access to the Atlassian servers, for example, by attempting to use the following example command the marketplace.atlassian.com server from the computer that hosts the Atlassian application. For more details, please refer to our documentation: Problems Connecting to the Atlassian Marketplace
Linux example
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curl -v -X GET https://marketplace.atlassian.com/healthcheck
Whitelist Domains and Ports:
Allow connections to the following domains on port 443:
*.
atlassian.com
(includes marketplace.atlassian.com, marketplace-cdn.atlassian.com, id.atlassian.com, maven.atlassian.com, etc.)*.
cloudfront.net
(for certain Marketplace assets like screenshots and logos)
Update Configuration
Ensure that your firewall, proxy, or load balancer settings are updated to permit traffic to these domains and ports. For more details please check our documentation: Configuring Marketplace connectivity
Workaround:
If updating network settings is not immediately feasible, you can use the following workaround:
Manual Plugin Upload:
Download the SSO plugin for Atlassian Data Center manually from the Marketplace.
In your Bamboo UI, navigate to the Cog icon > Manage Apps > Upload app, and add the plugin from the downloaded file.
Enable Plugin Upload Option:
If the 'Upload app' button is not visible, add the flag
-Dupm.plugin.upload.enabled=true
to your Bamboo System Properties.Restart Bamboo to apply the changes.
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