Bamboo build result summary Jira issue keys are pointing to wrong Jira instance

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

If you have integrated Bamboo with a Jira application you can view linked Jira application issues in the Issues tab of the Plan summary page and Build result summary page.

When you have multiple Jira applications linked to a Bamboo application, you may see that the Issues tab Jira links point to the wrong Jira application.

Diagnosis

After migrating your Jira server application to Jira cloud you may see your Bamboo Issues  URLs are still pointing to your old Jira server instance.

(Auto-migrated image: description temporarily unavailable)

Cause

This behaviour was due to Bamboo application checking the primary Application link first to direct the Jira Issues URL.

(Auto-migrated image: description temporarily unavailable)

Solution

  1. Log into Bamboo application and go to 'Application Links'

  2.  Select the correct Jira application you would like to mark as Primary and select 'Make primary'

(Auto-migrated image: description temporarily unavailable)
Updated on March 11, 2025

Still need help?

The Atlassian Community is here for you.