Bamboo artifacts grayed out and not available for download
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
At times, after running a build where an artifact is generated, the artifact shows grayed out and is not available for download.
Environment
All Bamboo versions configured to use Bamboo server artifact handler.
Diagnosis
In Bamboo Build dashboard > Artifacts tab, the artifact is grayed out and not clickable for download.

Cause
The issue occurs when the artifact folder is missing in the <BAMBOO_HOME>/shared/artifacts/<PLAN_KEY>/shared/<BUILD_NUMBER>/
.
Please be aware that Bamboo is not able to delete artifacts through its default settings unless the expiry is set to do this.
Solution
There are two options to resolve this issue:
Option 1 (recommended):
Re-run the builds with missing artifacts. This action will generate the artifact again using the same settings as the original build.
Option 2:
If you have a backup of the artifact folder and its content, copy and paste it into
<BAMBOO_HOME>/shared/artifacts/<PLAN_KEY>/shared/<BUILD_NUMBER>/
. The complete path should be<BAMBOO_HOME>/shared/artifacts/<PLAN_KEY>/shared/<BUILD_NUMBER>/<ARTIFACT_FOLDER>/<ARTIFACT_FILE>
.Please replace the BAMBOO_HOME, PLAN_KEY, and BUILD_NUMBER accordingly.
After applying any of the above options, the artifact name will appear in blue, being clickable and ready to be downloaded.
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