Bamboo-artifactory-plugin got disabled post Bamboo Data center upgrade

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

This knowledge base article talks about a scenario were an external plugin named Jfrog Bamboo Artifactory Plugin was not getting enabled after the plugin was upgraded to the latest version on the Bamboo server. 

This page explain about the issue related to this particular plugin, but the cause and the solution would be applicable for any other external plugins having the same problem. 

Environment

Issue was seen on Bamboo 9.6.4 and Jfrog Bamboo Artifactory Plugin version3.3.3 but the solution is applicable for any other supported version of Bamboo and the plugin.

Diagnosis

Looking at <bamboo-home>logs>atlassian-bamboo.log file below we can see the below error related to the plugin 

1) Bamboo is not able to identify the plugin JAR file >File must be a jar: /var/atlassian/application-data/bamboo/caches/plugins/transformed-plugins/plugin.10656268715588148989.bamboo-artifactory-plugin-3.3.3_1705662742570.jar

1 2 3 4 5 6 ERROR [main] [OsgiHeaderUtil] Cannot get manifest resource from plugin artifact 'plugin.10656268715588148989.bamboo-artifactory-plugin-3.3.3_1705662742570.jar': Cannot open JAR file: /var/atlassian/application-data/bamboo/caches/plugins/transformed-plugins/plugin.10656268715588148989.bamboo-artifactory-plugin-3.3.3_1705662742570.jar ERROR [main] [ScanningPluginLoader] Unable to deploy plugin 'org.jfrog.bamboo.bamboo-artifactory-plugin' from 'Unit: /var/atlassian/application-data/bamboo/shared/plugins/plugin.10656268715588148989.bamboo-artifactory-plugin-3.3.3.jar (1705662742570)'. ERROR [main] [ScanningPluginLoader] Because of the following exception: java.lang.IllegalArgumentException: File must be a jar: /var/atlassian/application-data/bamboo/caches/plugins/transformed-plugins/plugin.10656268715588148989.bamboo-artifactory-plugin-3.3.3_1705662742570.jar

2) Going to the⚙️ > Overview > Manage Appspage on the Bamboo GUI, we can see that the plugin is in a disabled state and below information is shown in the support zip related to the plugin. 

1 2 3 4 5 6 7 8 9 <plugin> <key>org.jfrog.bamboo.bamboo-artifactory-plugin</key> <name>org.jfrog.bamboo.bamboo-artifactory-plugin</name> <version>0.0</version> <vendor>(unknown)</vendor> <status>INSTALLED</status> <framework-version>1</framework-version> <bundled>User installed</bundled> </plugin>

Cause

The user which is running the Bamboo service is not having the correct access to the Jar or the folder or the plugin Jar file is corrupted.

Solution

1) The first step is to stop your Bamboo Instance and take a backup of <bamboo-home>/caches folder.

2) Please delete all the content from <bamboo-home>/caches folder and make sure the Bamboo user which is running the Bamboo service is having full read/write access to this folder.

3) Next validate if the plugin jar is present in <bamboo-home>shared>plugins folder. Please validate if the permission of the Bamboo user is correct on the jar file and if the jar file is not corrupted, if you are unsure if the jar is present or not you can download the plugin jar fromJFrog Artifactory for Bamboo and place the file there are make sure permission and ownership is provided to the bamboo user which is running the service.

5) Once this is done, you can restart your Bamboo service and check if the plugin is enabled.

Updated on March 11, 2025

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