After updating a Windows server, Bamboo requests a license key after startup
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After upgrading the Windows Server operating system and starting Bamboo, the application startup stops requesting a license key.

Environment
Windows
Bamboo 7, 8
Bamboo data is stored on C:\Users
Diagnosis
Under rare circumstances, Bamboo will have its <bamboo-home>\bamboo.cfg.xml
recreated with empty content after a Windows update
Cause
Due to a bug on Windows KB4532693 (details here), the files located at C:\Users
may be lost or misplaced after a Windows Update. This includes any Bamboo configuration files. When the <bamboo-home>\bamboo.cfg.xml
file does not exist, the Bamboo startup process will consider it as a new installation and request the license key as the initial setup process.
When the Bamboo application startup process running as a service is executed at the same time as the file migration task reported on KB4532693, Bamboo configuration files may not be available on the Bamboo Home folder, making the Bamboo startup process create a new environment setup.
Solution
Initially, you might find the original file still exists as
bamboo.cfg.xml
. If this is the case, please check its contents and validate that it is a complete setup that points to the correct database. Once confirmed, feel free to restore it overbamboo.cfg.xml
If restoring only the configuration file doesn't work, the Windows bug may have affected more files. In this case, restore the whole
<bamboo-home>
and<bamboo-install>
from a previous Backup, then start Bamboo againAs advised in the Installing Bamboo on Windows guide, please refrain from using Windows security-controlled folders such as
C:\Users
,C:\Windows
,C:\Program Files
, etcOptionally move the Bamboo Home location to a different place
Was this helpful?