Unable to login using Microsoft SSO with error "Sorry, we're having trouble signing you in."

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

When a user attempts to log in to their Atlassian account, they are redirected to the Microsoft login screen and encounter the following error message:

Sorry, but we're having trouble signing you in. (...) Your administrator has configured the application Atlassian Cloud ('xxxxxx-xxxx-xxxx-xxxxx-xxxxxx') to block users unless they are specifically granted ('assigned') access to the application.

Diagnosis

  1. Assign the user to the authentication policy that enforces SAML SSO.

  2. Don't assign the user to the Atlassian Cloud app in Microsoft Entra ID.

Cause

SAML SSO login is enforced, but the user is not assigned in Microsoft Entra ID

This issue arises when user login is enforced with SAML SSO, but the user has not been assigned to the Atlassian Cloud app in Microsoft Entra ID.

Solution

To fix the issue, assign the user to the Atlassian Cloud app in Microsoft Entra ID. If the error is related to OAuth authentication, ensure that the necessary Atlassian Cloud application has been added to Azure AD under Enterprise Applications. Refer to the Azure AD setup documentation for more details.

A temporary solution is to unassign the user from the authentication policy that enforces SAML SSO.

The content of this article has been generated by AI

Updated on December 11, 2025

Still need help?

The Atlassian Community is here for you.