AADSTS750054 error while trying to login to Atlassian Cloud via Azure
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
User tries to log in to Atlassian Cloud via SAML SSO with Azure and gets an Error AADSTS750054 - SAMLRequest or SAMLResponse must be present as query string parameters in HTTP request for SAML Redirect binding.
Environment
This KB applies to organisations that have Atlassian Guard configured and integrated SAML Single Sign-On with Azure.
Diagnosis
This implies that the user did an SP-initiated login, but the parameters sent from Atlassian were wrong.
Solution
Open Azure AD and Navigate to Enterprise Applications > Atlassian Cloud App > Single Sign On
On the Set up Single Sign-On with SAML page, scroll down to Set Up Atlassian Cloud.
Copy Azure AD Identifier value from Azure portal, and compare it with Identity Provider Entity ID textbox in Atlassian. If the value differs, update the Identity Provider Entity ID textbox in Atlassian with the new value.
Copy Login URL value from Azure portal, and compare it with Identity Provider SSO URL textbox in Atlassian. If the value differs, update the Identity Provider SSO URL textbox in Atlassian with the new value.
Add and Save the SAML Configuration in Atlassian.
Test SAML SSO again
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